lunes, 26 de octubre de 2020

Problema en VMware: the ovf package is signed with an invalid certificate

 Seguro que os ha pasado alguna vez que desplegando un OVA os encontráis con el siguiente aviso:

Esto es debido a que, como bien dice el mensaje, el certificado que está incluido no es válido por algún motivo. Una faena que no tiene remedio si por ejemplo, no hay una nueva version para una OVA concreta, o hay que utilizar una versión específica que por antigüedad, trae el certificado caducado.

Tenemos una solución para esto, facilitada por una herramienta de VMware: las OVF Tools, disponibles en este enlace: https://code.vmware.com/tool/ovf/4.1.0

Una vez hagamos login en la web de vmware para su descarga, descargamos la version que más nos interese,


Instalamos,


y ejecutamos con el siguiente comando:

C:\Program Files\VMware\VMware OVF Tool>ovftool --acceptAllEulas <SOURCE_OVA.OVA>  <DESTINATION_OVF.OVF> --skipManifestCheck

Puede pasar que de fallo el agregado final, en cuyo caso, también parece funcionar sin esa sentencia:

Finalmente, genera la imagen:



Hay otra solución que se muestra válida, y es realizar la importación desde la interfaz html5. Avisa del certificado inválido, pero permite continuar:



Ambas soluciones son efectivas.

No hay comentarios:

Publicar un comentario

¡Gracias por colaborar en este blog con tus comentarios! :)